Upgrade to v2 fails

Nov 8, 2008 at 8:43 PM
Hi Danny

I'm trying to install v2 after installing v1, but the v2 install keeps asking for v1 .msi file resulting in a v1 installation, even after uninstalling v1 first.

Any suggestions ?

Theo Ekelmans

theo@ekelmans.com
Coordinator
Nov 10, 2008 at 6:23 PM

Hi Theo,

Not sure why it's doing that. Could you send me info on the exact message?

Thanks,

Danny

Dec 13, 2008 at 10:24 AM
Hi Danny,

I've found it....

Right click on SqlInternalsViewer_20081102.1 and run uninstall removed the old file and most registry entries.

After cleaning the registry for all SqlInternals entries, Internals Viewer 2 Alpha 20081116.1 did install.

But now i have the same issue as Neo100, there is no add-in visible in SSMS.

Any idea how to register the add-in to SSMS?

Theo

Coordinator
Dec 15, 2008 at 6:29 PM
Edited Dec 15, 2008 at 6:29 PM
Hi Theo,

Sometimes when the add-in has failed once it gets turned off.

Try changing the LoadBehavior value to 1 in the registry - HKEY_CURRENT_USER\Software\Microsoft\Microsoft SQL Server\100\Tools\Shell\Addins\InternalsViewer.SSMSAddIn.Connect or HKEY_CURRENT_USER\Software\Microsoft\Microsoft SQL Server\90\Tools\Shell\Addins\InternalsViewer.SSMSAddIn.Connect for 2005.

Let me know if it still doesn't work.

Danny